Workaround for Freezing/Slow Operation on Systems with Intel Core Ultra 7 165H/U or Similar AI-Enabled Processors

Issue

Some systems, such as Dell Precision 5690s, experience freezing and slow operation in Zoom, File Explorer, and other applications when using an Intel Core Ultra 7 165H/U or similar AI-enabled processors.

Environment

Windows computers with Intel Core Ultra 7 165H/U or similar AI-enabled processors.

Cause

The freezing and slow operations have been traced back to the AI-enabled processors' Intel(R) AI Boost function.

Resolution

The freezing and slow operation can be remedied by updating or disabling Intel(R) AI Boost through Device Manager.

Updates for Intel(R) AI Boost can be found at the following link: Intel® NPU Driver - Windows*

If the system's issues do not resolve after installing the NPU update, Intel(R) AI Boost can be disabled through the following process:

  1. Open Device Manager
  2. Navigate to Neural Processors
  3. Find Intel(R) AI Boost in Neural Processors' drop-down menu
  4. Right-Click Intel(R) AI Boost and disable the driver

Alternatively, running the following PowerShell command as administrator will disable the driver in the same capacity as the Device Manager process above:

Get-PnpDevice -FriendlyName "Intel(R) AI Boost" | Disable-PnpDevice -Confirm:$False

External resources

Intel® NPU Driver - Windows*: https://www.intel.com/content/www/us/en/download/794734/intel-npu-driver-windows.html